Back to overview
Degraded

Drag and Drop Editor is unavailable

Oct 18 at 05:17pm EDT
Affected services
us.campaigndeputy.app

Resolved
Oct 18 at 06:00pm EDT

The drag and drop editor loads now. Our vendor has resolved the issue.

Created
Oct 18 at 05:17pm EDT

The drag and drop email editor, form and RSVP editor is currently unavailable. We have contacted the third party vendor to request an ETA when services will be re-enabled.