Back to overview
Degraded

Email and Import Delays

Sep 25 at 01:49pm EDT
Affected services
us.campaigndeputy.app

Resolved
Sep 25 at 03:26pm EDT

Email data has all been processed. Extra monitoring has been put in place for this specific style of incident to be notified quicker.

Updated
Sep 25 at 02:13pm EDT

All imports have finished. Email events are still processing.

Created
Sep 25 at 01:49pm EDT

Due to some weekend maintenance, the email and imports are currently delayed.