Back to overview
Downtime
Marketing Site Unavailable
Jun 12 at 02:02pm EDT
Affected services
campaigndeputy.com
Resolved
Jun 12 at 05:38pm EDT
Cloudflare has fully resolved the issue. Our marketing site is now available., The main app and digital experiences were unaffected during this time.
Affected services
campaigndeputy.com
Updated
Jun 12 at 04:09pm EDT
Cloudflare is restoring services and our marketing site is being returned properly more often. This is not yet a full recovery as we wait for the all clear from Cloudflare.
Affected services
campaigndeputy.com
Created
Jun 12 at 02:02pm EDT
Our marketing site is unavailable due to an issue with Cloudflare. You can access the application by going directly to the login page at https://us.campaigndeputy.app/
Affected services
campaigndeputy.com