Back to overview
Degraded

ActBlue Processing Delays

Aug 27, 2022 at 2:29pm UTC
Affected services
us.campaigndeputy.app

Resolved
Aug 28, 2022 at 9:05am UTC

All ActBlue contributions have been processed now.

Created
Aug 27, 2022 at 2:29pm UTC

ActBlue contributions are behind in processing. We are working to process the backlog at the moment